<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-8469139019079365",
    enable_page_level_ads: true
  });
</script>
    
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="https://theusbport.com/xmlrpc.php" />
    <script data-cfasync="false" type="text/javascript">var ewww_webp_supported=!1;function check_webp_feature(A,e){if(e=void 0!==e?e:function(){},ewww_webp_supported)e(ewww_webp_supported);else{var w=new Image;w.onload=function(){ewww_webp_supported=0<w.width&&0<w.height,e&&e(ewww_webp_supported)},w.onerror=function(){e&&e(!1)},w.src="data:image/webp;base64,"+{alpha:"UklGRkoAAABXRUJQVlA4WAoAAAAQAAAAAAAAAAAAQUxQSAwAAAARBxAR/Q9ERP8DAABWUDggGAAAABQBAJ0BKgEAAQAAAP4AAA3AAP7mtQAAAA=="}[A]}}check_webp_feature("alpha");</script><script data-cfasync="false" type="text/javascript">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</script>
		<!-- All in One SEO 4.1.4.5 -->
		<title>Elon Musk’s 79.1 Million Followers Want Him to Buy Twitter or Build another Platform</title>
		<meta name="description" content="In response to a rhetorical question asked by billionaire Elon Musk, his online followers have asked him to either acquire Twitter or build a social media platform. Expressing fear that the microblogging platform was hindering free speech, Musk had asked what should be done over Twitter before his 79.1 million Twitter offered the advice. “Given that […]" />
		<meta name="robots" content="max-image-preview:large" />
		<meta name="google-site-verification" content="ti4poDPyfji44oE58UNCsu5DMHajkjmP__x3pfB9KP4" />
		<link rel="canonical" href="https://theusbport.com/elon-musks-79-1-million-followers-want-him-to-buy-twitter-or-build-another-platform/35168" />
		<meta name="google" content="nositelinkssearchbox" />
		<script type="application/ld+json" class="aioseo-schema">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</script>
		<!-- All in One SEO -->

<meta property="og:image" content="https://theusbport.com/wp-content/uploads/2022/03/Elon-Musks-79.1-Million-Followers-Want-Him-to-Buy-Twitter-or-Build-another-Platform.jpg" /><meta name="author" content="Pablo Luna">
<link rel="icon" type="image/png" href="https://theusbport.com/wp-content/uploads/2016/05/Logo-TUP-favi.png"><link rel="amphtml" href="https://theusbport.com/elon-musks-79-1-million-followers-want-him-to-buy-twitter-or-build-another-platform/35168/amp" /><meta name="generator" content="AMP for WP 1.0.77.33"/><link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The USB Port &raquo; Feed" href="https://theusbport.com/feed" />
<link rel="alternate" type="application/rss+xml" title="The USB Port &raquo; Comments Feed" href="https://theusbport.com/comments/feed" />
<!-- This site is optimized with the WordPress Google News Plugin v2.7.6.1 - http://www.googlenewsplugin.com/ -->
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"Article","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/theusbport.com\/elon-musks-79-1-million-followers-want-him-to-buy-twitter-or-build-another-platform\/35168"},"headline":"Elon Musk\u2019s 79.1 Million Followers Want Him to Buy Twitter or Build another Platform","url":"https:\/\/theusbport.com\/elon-musks-79-1-million-followers-want-him-to-buy-twitter-or-build-another-platform\/35168","image":{"@type":"ImageObject","url":"","height":413,"width":732},"thumbnailUrl":"","dateCreated":"2022-03-27T06:10:26-07:00","datePublished":"2022-03-27T06:10:26-07:00","dateModified":"2022-03-28T06:12:21-07:00","author":{"@type":"Person","name":"Pablo Luna"},"publisher":{"@type":"Choose","name":"TheUSBport","url":"https:\/\/theusbport.com","logo":{"@type":"ImageObject","url":"","height":"250","width":"250"},"sameAs":["https:\/\/www.facebook.com\/theusbport","https:\/\/twitter.com\/theusbport_com"]},"description":"","articleSection":"Tech","creator":"Pablo Luna","keywords":[""]}</script>
<meta name="news_keywords" content="" />
<!-- / WordPress Google News Plugin. -->
<link rel="alternate" type="application/rss+xml" title="The USB Port &raquo; Elon Musk’s 79.1 Million Followers Want Him to Buy Twitter or Build another Platform Comments Feed" href="https://theusbport.com/elon-musks-79-1-million-followers-want-him-to-buy-twitter-or-build-another-platform/35168/feed" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/theusbport.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.8.4"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://theusbport.com/wp-includes/css/dist/block-library/style.min.css?ver=5.8.4' type='text/css' media='all' />
<link rel='stylesheet' id='pc-style-css'  href='https://theusbport.com/wp-content/plugins/pricecomparison/style.css?ver=5.8.4' type='text/css' media='all' />
<link rel='stylesheet' id='google_font_roboto-css'  href='https://fonts.googleapis.com/css?family=Roboto%3A500%2C400italic%2C700%2C900%2C500italic%2C400%2C300&#038;ver=5.8.4' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A400%2C700%7CMallanna%3A400%2C700&#038;ver=5.8.4' type='text/css' media='all' />
<link rel='stylesheet' id='js_composer_front-css'  href='https://theusbport.com/wp-content/plugins/js_composer/assets/css/js_composer.min.css?ver=4.11.2' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css'  href='https://theusbport.com/wp-content/themes/Newspaper/style.css?ver=7.1.1' type='text/css' media='all' />
<script type='text/javascript' src='https://theusbport.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://theusbport.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<link rel="https://api.w.org/" href="https://theusbport.com/wp-json/" /><link rel="alternate" type="application/json" href="https://theusbport.com/wp-json/wp/v2/posts/35168" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://theusbport.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://theusbport.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://theusbport.com/?p=35168' />
<link rel="alternate" type="application/json+oembed" href="https://theusbport.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftheusbport.com%2Felon-musks-79-1-million-followers-want-him-to-buy-twitter-or-build-another-platform%2F35168" />
<link rel="alternate" type="text/xml+oembed" href="https://theusbport.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftheusbport.com%2Felon-musks-79-1-million-followers-want-him-to-buy-twitter-or-build-another-platform%2F35168&#038;format=xml" />
	<style type="text/css" media="screen">
	h2.entry-subtitle {
		display: block; /* Some themes apparently aren't styled correctly with h2 tags. */
		font-size: 1.5em; /* Scaling higher since subtitles will no longer be wrapped in h1 tags. */		
	}
	#comments .comments-title h2.entry-subtitle {
		display: none;
		font-size: 1em;
	}
	</style><!--[if lt IE 9]><script src="https://html5shim.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
    <meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="https://theusbport.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><!--[if IE  8]><link rel="stylesheet" type="text/css" href="https://theusbport.com/wp-content/plugins/js_composer/assets/css/vc-ie8.min.css" media="screen"><![endif]-->
<!-- JS generated by theme -->

<script>
    
    

	    var tdBlocksArray = []; //here we store all the items for the current page

	    //td_block class - each ajax block uses a object of this class for requests
	    function tdBlock() {
		    this.id = '';
		    this.block_type = 1; //block type id (1-234 etc)
		    this.atts = '';
		    this.td_column_number = '';
		    this.td_current_page = 1; //
		    this.post_count = 0; //from wp
		    this.found_posts = 0; //from wp
		    this.max_num_pages = 0; //from wp
		    this.td_filter_value = ''; //current live filter value
		    this.is_ajax_running = false;
		    this.td_user_action = ''; // load more or infinite loader (used by the animation)
		    this.header_color = '';
		    this.ajax_pagination_infinite_stop = ''; //show load more at page x
	    }


        // td_js_generator - mini detector
        (function(){
            var htmlTag = document.getElementsByTagName("html")[0];

            if ( navigator.userAgent.indexOf("MSIE 10.0") > -1 ) {
                htmlTag.className += ' ie10';
            }

            if ( !!navigator.userAgent.match(/Trident.*rv\:11\./) ) {
                htmlTag.className += ' ie11';
            }

            if ( /(iPad|iPhone|iPod)/g.test(navigator.userAgent) ) {
                htmlTag.className += ' td-md-is-ios';
            }

            var user_agent = navigator.userAgent.toLowerCase();
            if ( user_agent.indexOf("android") > -1 ) {
                htmlTag.className += ' td-md-is-android';
            }

            if ( -1 !== navigator.userAgent.indexOf('Mac OS X')  ) {
                htmlTag.className += ' td-md-is-os-x';
            }

            if ( /chrom(e|ium)/.test(navigator.userAgent.toLowerCase()) ) {
               htmlTag.className += ' td-md-is-chrome';
            }

            if ( -1 !== navigator.userAgent.indexOf('Firefox') ) {
                htmlTag.className += ' td-md-is-firefox';
            }

            if ( -1 !== navigator.userAgent.indexOf('Safari') && -1 === navigator.userAgent.indexOf('Chrome') ) {
                htmlTag.className += ' td-md-is-safari';
            }

        })();




        var tdLocalCache = {};

        ( function () {
            "use strict";

            tdLocalCache = {
                data: {},
                remove: function (resource_id) {
                    delete tdLocalCache.data[resource_id];
                },
                exist: function (resource_id) {
                    return tdLocalCache.data.hasOwnProperty(resource_id) && tdLocalCache.data[resource_id] !== null;
                },
                get: function (resource_id) {
                    return tdLocalCache.data[resource_id];
                },
                set: function (resource_id, cachedData) {
                    tdLocalCache.remove(resource_id);
                    tdLocalCache.data[resource_id] = cachedData;
                }
            };
        })();

    
    
var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":228},{"limitBottom":1018,"sidebarWidth":300},{"limitBottom":1140,"sidebarWidth":324}];
var td_ajax_url="https:\/\/theusbport.com\/wp-admin\/admin-ajax.php?td_theme_name=Newspaper&v=7.1.1";
var td_get_template_directory_uri="https:\/\/theusbport.com\/wp-content\/themes\/Newspaper";
var tds_snap_menu="";
var tds_logo_on_sticky="";
var tds_header_style="3";
var td_please_wait="Please wait...";
var td_email_user_pass_incorrect="User or password incorrect!";
var td_email_user_incorrect="Email or username incorrect!";
var td_email_incorrect="Email incorrect!";
var tds_more_articles_on_post_enable="";
var tds_more_articles_on_post_time_to_wait="";
var tds_more_articles_on_post_pages_distance_from_top=0;
var tds_theme_color_site_wide="#41baff";
var tds_smart_sidebar="enabled";
var tdThemeName="Newspaper";
var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";
var td_magnific_popup_translation_tNext="Next (Right arrow key)";
var td_magnific_popup_translation_tCounter="%curr% of %total%";
var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";
var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";
var td_ad_background_click_link="";
var td_ad_background_click_target="";
</script>


<!-- Header style compiled by theme -->

<style>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</style>

<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-64277760-1', 'auto');
  ga('send', 'pageview');

</script>		<style type="text/css" id="wp-custom-css">
			.sponsor-label {
	font-size:12px;
	font-weight:bold;
	color:#fff;
	padding:0px 8px;
	text-align:center;
	width:100px;
	background-color:#41baff;
	box-sizing:border-box;
	text-transform:uppercase;
	/*margin-top:-25px;*/
	margin-bottom:15px;
	position: absolute;
  top: 0;
  z-index: 100;
}		</style>
		<noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript></head>

<body data-rsssl=1 class="post-template-default single single-post postid-35168 single-format-standard elon-musks-79-1-million-followers-want-him-to-buy-twitter-or-build-another-platform single_template_2 wpb-js-composer js-comp-ver-4.11.2 vc_responsive td-boxed-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">
<script data-cfasync="false">if(ewww_webp_supported){document.body.classList.add("webp-support");}</script>

        <div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>
    
    <div class="td-menu-background"></div>
<div id="td-mobile-nav">
    <div class="td-mobile-container">
        <!-- mobile menu top section -->
        <div class="td-menu-socials-wrap">
            <!-- socials -->
            <div class="td-menu-socials">
                
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.facebook.com/theusbport" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://twitter.com/theusbport_com" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>            </div>
            <!-- close button -->
            <div class="td-mobile-close">
                <a href="#"><i class="td-icon-close-mobile"></i></a>
            </div>
        </div>

        <!-- login section -->
        
        <!-- menu section -->
        <div class="td-mobile-content">
            <div class="menu-main-menu-container"><ul id="menu-main-menu" class="td-mobile-main-menu"><li id="menu-item-7903" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-first menu-item-7903"><a href="https://theusbport.com/category/tech">Tech</a></li>
<li id="menu-item-7896" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7896"><a href="https://theusbport.com/category/apps">Apps</a></li>
<li id="menu-item-7902" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7902"><a href="https://theusbport.com/category/social">Social</a></li>
<li id="menu-item-9681" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9681"><a href="https://theusbport.com/category/us-news">US News</a></li>
<li id="menu-item-7899" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7899"><a href="https://theusbport.com/category/entertainment">Entertainment</a></li>
<li id="menu-item-7901" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7901"><a href="https://theusbport.com/category/science">Science</a></li>
<li id="menu-item-7898" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7898"><a href="https://theusbport.com/category/editorials">Editorials</a></li>
<li id="menu-item-7897" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7897"><a href="https://theusbport.com/category/autos">Autos</a></li>
<li id="menu-item-7900" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7900"><a href="https://theusbport.com/category/health">Health</a></li>
</ul></div>        </div>
    </div>

    <!-- register/login section -->
    </div>    <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
	<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
		<form method="get" class="td-search-form" action="https://theusbport.com/">
			<!-- close button -->
			<div class="td-search-close">
				<a href="#"><i class="td-icon-close-mobile"></i></a>
			</div>
			<div role="search" class="td-search-input">
				<span>Search</span>
				<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
			</div>
		</form>
		<div id="td-aj-search-mob"></div>
	</div>
</div>    
    
    <div id="td-outer-wrap">
    
        <!--
Header style 3
-->

<div class="td-header-wrap td-header-style-3">

    <div class="td-header-top-menu-full">
        <div class="td-container td-header-row td-header-top-menu">
            
    <div class="top-bar-style-1">
        
<div class="td-header-sp-top-menu">


	<div class="menu-top-container"><ul id="menu-secondary" class="top-header-menu"><li id="menu-item-229" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-229"><a href="https://theusbport.com/about">About</a></li>
<li id="menu-item-233" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-233"><a href="https://theusbport.com/team">Team</a></li>
<li id="menu-item-3516" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-3516"><a href="https://theusbport.com/advertise">Advertise</a></li>
<li id="menu-item-231" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-231"><a href="https://theusbport.com/contact">Contact us</a></li>
<li id="menu-item-232" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-232"><a href="https://theusbport.com/privacy-policy">Privacy Policy</a></li>
<li id="menu-item-679" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-679"><a href="https://theusbport.com/terms">Terms of Use</a></li>
<li id="menu-item-234" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-234"><a href="https://theusbport.com/tip">Tip us</a></li>
</ul></div></div>
        <div class="td-header-sp-top-widget">
    
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.facebook.com/theusbport" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://twitter.com/theusbport_com" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span></div>
    </div>

<!-- LOGIN MODAL -->

                <div  id="login-form" class="white-popup-block mfp-hide mfp-with-anim">
                    <ul class="td-login-tabs">
                        <li><a id="login-link" class="td_login_tab_focus">LOG IN</a></li>
                    </ul>



                    <div class="td-login-wrap">
                        <div class="td_display_err"></div>

                        <div id="td-login-div" class="">
                            <div class="td-login-panel-title">Welcome! Log into your account</div>
                            <input class="td-login-input" type="text" name="login_email" id="login_email" placeholder="your username" value="" required>
                            <input class="td-login-input" type="password" name="login_pass" id="login_pass" value="" placeholder="your password" required>
                            <input type="button" name="login_button" id="login_button" class="wpb_button btn td-login-button" value="Log In">


                            <div class="td-login-info-text"><a href="#" id="forgot-pass-link">Forgot your password?</a></div>


                        </div>

                        

                         <div id="td-forgot-pass-div" class="td-display-none">
                            <div class="td-login-panel-title">Recover your password</div>
                            <input class="td-login-input" type="text" name="forgot_email" id="forgot_email" placeholder="your email" value="" required>
                            <input type="button" name="forgot_button" id="forgot_button" class="wpb_button btn td-login-button" value="Send My Pass">
                        </div>




                    </div>
                </div>
                        </div>
    </div>

    <div class="td-banner-wrap-full">
        <div class="td-container td-header-row td-header-header">
            <div class="td-header-sp-logo">
                        <a class="td-main-logo" href="https://theusbport.com/">
            <img class="td-retina-data" data-retina="https://theusbport.com/wp-content/uploads/2016/05/Full-logo-TUP-544px.png" src="https://theusbport.com/wp-content/uploads/2016/05/Full-logo-TUP-272px.png" alt="The USB Port" title="The USB Port"/>
            <span class="td-visual-hidden">The USB Port</span>
        </a>
                </div>
            <div class="td-header-sp-recs">
                <div class="td-header-rec-wrap">
    
 <!-- A generated by theme --> 

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-header">
<script type="text/javascript">
var td_screen_width = document.body.clientWidth;

                    if ( td_screen_width >= 1140 ) {
                        /* large monitors */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:728px;height:90px" data-ad-client="ca-pub-8469139019079365" data-ad-slot="3820330335"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
            
	                    if ( td_screen_width >= 1019  && td_screen_width < 1140 ) {
	                        /* landscape tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-8469139019079365" data-ad-slot="3820330335"></ins>');
	                        (adsbygoogle = window.adsbygoogle || []).push({});
	                    }
	                
                    if ( td_screen_width >= 768  && td_screen_width < 1019 ) {
                        /* portrait tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-8469139019079365" data-ad-slot="3820330335"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                
                    if ( td_screen_width < 768 ) {
                        /* Phones */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:320px;height:50px" data-ad-client="ca-pub-8469139019079365" data-ad-slot="3820330335"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                </script>
</div>

 <!-- end A --> 


</div>            </div>
        </div>
    </div>

    <div class="td-header-menu-wrap-full">
        <div class="td-header-menu-wrap">
            <div class="td-container td-header-row td-header-main-menu black-menu">
                <div id="td-header-menu" role="navigation">
    <div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
    <div class="td-main-menu-logo td-logo-in-header">
                <a class="td-main-logo" href="https://theusbport.com/">
            <img class="td-retina-data" data-retina="https://theusbport.com/wp-content/uploads/2016/05/Full-logo-TUP-544px.png" src="https://theusbport.com/wp-content/uploads/2016/05/Full-logo-TUP-272px.png" alt="The USB Port" title="The USB Port"/>
        </a>
        </div>
    <div class="menu-main-menu-container"><ul id="menu-main-menu-1" class="sf-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-first td-menu-item td-normal-menu menu-item-7903"><a href="https://theusbport.com/category/tech">Tech</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-7896"><a href="https://theusbport.com/category/apps">Apps</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-7902"><a href="https://theusbport.com/category/social">Social</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-9681"><a href="https://theusbport.com/category/us-news">US News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-7899"><a href="https://theusbport.com/category/entertainment">Entertainment</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-7901"><a href="https://theusbport.com/category/science">Science</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-7898"><a href="https://theusbport.com/category/editorials">Editorials</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-7897"><a href="https://theusbport.com/category/autos">Autos</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-7900"><a href="https://theusbport.com/category/health">Health</a></li>
</ul></div></div>


<div class="td-search-wrapper">
    <div id="td-top-search">
        <!-- Search -->
        <div class="header-search-wrap">
            <div class="dropdown header-search">
                <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
                <a id="td-header-search-button-mob" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
            </div>
        </div>
    </div>
</div>

<div class="header-search-wrap">
	<div class="dropdown header-search">
		<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
			<form method="get" class="td-search-form" action="https://theusbport.com/">
				<div role="search" class="td-head-form-search-wrap">
					<input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
				</div>
			</form>
			<div id="td-aj-search"></div>
		</div>
	</div>
</div>            </div>
        </div>
    </div>

</div><div class="td-main-content-wrap">

    <div class="td-container td-post-template-2">
        <article id="post-35168" class="post-35168 post type-post status-publish format-standard has-post-thumbnail hentry category-tech" itemscope itemtype="https://schema.org/Article">
            <div class="td-pb-row">
                <div class="td-pb-span12">
                    <div class="td-post-header">
                        <div class="td-crumb-container"></div>

                        
                        <header class="td-post-title">
                            <h1 class="entry-title">Elon Musk’s 79.1 Million Followers Want Him to Buy Twitter or Build another Platform</h1>

                            

                            <div class="td-module-meta-info">
                                <div class="td-post-author-name">By <a href="https://theusbport.com/author/pablo">Pablo Luna</a> - </div>                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2022-03-27T06:10:26+00:00" >March 27, 2022</time></span>                                                                                            </div>

                        </header>
                    </div>
                </div>
            </div> <!-- /.td-pb-row -->

            <div class="td-pb-row">
                                            <div class="td-pb-span8 td-main-content" role="main">
                                <div class="td-ss-main-content">
                                    
        

        <div class="td-post-content">
            <div class="td-post-featured-image"><img width="696" height="393" class="entry-thumb ewww_webp" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" alt="Elon Musk’s 79.1 Million Followers Want Him to Buy Twitter or Build another Platform" title="Elon Musk’s 79.1 Million Followers Want Him to Buy Twitter or Build another Platform" data-src-img="https://theusbport.com/wp-content/uploads/2022/03/Elon-Musks-79.1-Million-Followers-Want-Him-to-Buy-Twitter-or-Build-another-Platform-696x393.jpg" data-src-webp="https://theusbport.com/wp-content/uploads/2022/03/Elon-Musks-79.1-Million-Followers-Want-Him-to-Buy-Twitter-or-Build-another-Platform-696x393.jpg.webp" data-eio="j" /><noscript><img width="696" height="393" class="entry-thumb" src="https://theusbport.com/wp-content/uploads/2022/03/Elon-Musks-79.1-Million-Followers-Want-Him-to-Buy-Twitter-or-Build-another-Platform-696x393.jpg" alt="Elon Musk’s 79.1 Million Followers Want Him to Buy Twitter or Build another Platform" title="Elon Musk’s 79.1 Million Followers Want Him to Buy Twitter or Build another Platform"/></noscript></div>
            <p>In response to a rhetorical question asked by billionaire Elon Musk, his online followers have asked him to either <a href="https://www.foxbusiness.com/politics/elon-musk-new-platform-needed-twitter-free-speech" target="_blank" rel="noopener noreferrer">acquire Twitter</a> or build a social media platform. Expressing fear that the microblogging platform was hindering free speech, Musk had asked what should be done over Twitter before his 79.1 million Twitter offered the advice.</p>
<p>&#8220;Given that Twitter serves as the de facto public town square, failing to adhere to free speech principles fundamentally undermines democracy,&#8221; Musk tweeted on Saturday. &#8220;What should be done?&#8221;</p>
<p>And then in a follow-up post, the billionaire had asked, &#8220;Is a new platform needed?&#8221;</p>
<p>Within one hour of posting his tweet, it was liked more than 62,000 times and retweeted more than 10,000 times. Some of the most prominent respondents were press secretary for Gov. Ron DeSantis of Florida, Christina Pushaw; former CIA analyst and conservative radio host, Buck Sexton; and radio host Jason Rantz among others.</p>
<p>The followers asked Musk to buy Twitter to break the power of “these psycho Silicon Valley libs” and to give room for free speech. If the Tesla co-founder and SpaceX CEO goes ahead to establish his own social media platform, he wouldn’t be the first billionaire to do so after frustration with mainstream online networks; former President Donald Trump did the same by launching Truth Social in February.</p>
<p>Trump launched Truth Social as part of Trump Media and Technology Group after Twitter banned him in January 2021 and Facebook and Instagram suspended him. Other social media platforms that also came into existence on account of the restrictions by major platforms include Rumble, Parler, and Getty. But will Musk move forward with his question? That remains to be seen.</p>
        </div>


        <footer>
                        
            <div class="td-post-source-tags">
                                            </div>

            <div class="td-post-sharing td-post-sharing-bottom "><span class="td-post-share-title">SHARE</span>
            <div class="td-default-sharing">
	            <a class="td-social-sharing-buttons td-social-facebook" href="http://www.facebook.com/sharer.php?u=https%3A%2F%2Ftheusbport.com%2Felon-musks-79-1-million-followers-want-him-to-buy-twitter-or-build-another-platform%2F35168" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-facebook"></i><div class="td-social-but-text">Facebook</div></a>
	            <a class="td-social-sharing-buttons td-social-twitter" href="https://twitter.com/intent/tweet?text=Elon+Musk%E2%80%99s+79.1+Million+Followers+Want+Him+to+Buy+Twitter+or+Build+another+Platform&url=https%3A%2F%2Ftheusbport.com%2Felon-musks-79-1-million-followers-want-him-to-buy-twitter-or-build-another-platform%2F35168&via=The+USB+Port"><i class="td-icon-twitter"></i><div class="td-social-but-text">Twitter</div></a>
	            <a class="td-social-sharing-buttons td-social-google" href="http://plus.google.com/share?url=https://theusbport.com/elon-musks-79-1-million-followers-want-him-to-buy-twitter-or-build-another-platform/35168" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-googleplus"></i></a>
	            <a class="td-social-sharing-buttons td-social-pinterest" href="http://pinterest.com/pin/create/button/?url=https://theusbport.com/elon-musks-79-1-million-followers-want-him-to-buy-twitter-or-build-another-platform/35168&amp;media=https://theusbport.com/wp-content/uploads/2022/03/Elon-Musks-79.1-Million-Followers-Want-Him-to-Buy-Twitter-or-Build-another-Platform.jpg&description=Elon+Musk%E2%80%99s+79.1+Million+Followers+Want+Him+to+Buy+Twitter+or+Build+another+Platform" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-pinterest"></i></a>
	            <a class="td-social-sharing-buttons td-social-whatsapp" href="whatsapp://send?text=Elon+Musk%E2%80%99s+79.1+Million+Followers+Want+Him+to+Buy+Twitter+or+Build+another+Platform%20-%20https%3A%2F%2Ftheusbport.com%2Felon-musks-79-1-million-followers-want-him-to-buy-twitter-or-build-another-platform%2F35168" ><i class="td-icon-whatsapp"></i></a>
            </div></div>                        <div class="td-author-name vcard author" style="display: none"><span class="fn"><a href="https://theusbport.com/author/pablo">Pablo Luna</a></span></div>	        <span style="display: none;" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Pablo Luna"></span><meta itemprop="datePublished" content="2022-03-27T06:10:26+00:00"><meta itemprop="dateModified" content="2022-03-28T06:12:21-07:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://theusbport.com/elon-musks-79-1-million-followers-want-him-to-buy-twitter-or-build-another-platform/35168"/><span style="display: none;" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span style="display: none;" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://theusbport.com/wp-content/uploads/2016/05/Full-logo-TUP-272px.png"></span><meta itemprop="name" content="The USB Port"></span><meta itemprop="headline " content="Elon Musk’s 79.1 Million Followers Want Him to Buy Twitter or Build another Platform"><span style="display: none;" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://theusbport.com/wp-content/uploads/2022/03/Elon-Musks-79.1-Million-Followers-Want-Him-to-Buy-Twitter-or-Build-another-Platform.jpg"><meta itemprop="width" content="732"><meta itemprop="height" content="413"></span>        </footer>

    <script>var block_td_uid_1_6243851771bb5 = new tdBlock();
block_td_uid_1_6243851771bb5.id = "td_uid_1_6243851771bb5";
block_td_uid_1_6243851771bb5.atts = '{"limit":6,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"","category_ids":"","custom_title":"","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"","td_ajax_filter_type":"td_custom_related","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_1_6243851771bb5_rand","offset":"","live_filter":"cur_post_same_categories","live_filter_cur_post_id":35168,"live_filter_cur_post_author":"32"}';
block_td_uid_1_6243851771bb5.td_column_number = "3";
block_td_uid_1_6243851771bb5.block_type = "td_block_related_posts";
block_td_uid_1_6243851771bb5.post_count = "6";
block_td_uid_1_6243851771bb5.found_posts = "2484";
block_td_uid_1_6243851771bb5.header_color = "";
block_td_uid_1_6243851771bb5.ajax_pagination_infinite_stop = "";
block_td_uid_1_6243851771bb5.max_num_pages = "414";
tdBlocksArray.push(block_td_uid_1_6243851771bb5);
</script><div class="td_block_wrap td_block_related_posts td_uid_1_6243851771bb5_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_1_6243851771bb5" ><h4 class="td-related-title"><a id="td_uid_2_624385179ae79" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="td_uid_1_6243851771bb5" href="#">RELATED ARTICLES</a><a id="td_uid_3_624385179ae80" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="td_uid_1_6243851771bb5" href="#">MORE FROM AUTHOR</a></h4><div id=td_uid_1_6243851771bb5 class="td_block_inner">

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://theusbport.com/pixel-6-smartphone-suffers-weaker-vibrations-from-notifications-after-update/35165" rel="bookmark" title="Pixel 6 Smartphone Suffers Weaker Vibrations from Notifications after Update"><img width="218" height="150" class="entry-thumb ewww_webp" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" alt="Pixel 6 Smartphone Suffers Weaker Vibrations from Notifications after Update" title="Pixel 6 Smartphone Suffers Weaker Vibrations from Notifications after Update" data-src-img="https://theusbport.com/wp-content/uploads/2022/03/Pixel-6-Smartphone-Suffers-Weaker-Vibrations-from-Notifications-after-Update-218x150.jpg" data-src-webp="https://theusbport.com/wp-content/uploads/2022/03/Pixel-6-Smartphone-Suffers-Weaker-Vibrations-from-Notifications-after-Update-218x150.jpg.webp" data-eio="j" /><noscript><img width="218" height="150" class="entry-thumb" src="https://theusbport.com/wp-content/uploads/2022/03/Pixel-6-Smartphone-Suffers-Weaker-Vibrations-from-Notifications-after-Update-218x150.jpg" alt="Pixel 6 Smartphone Suffers Weaker Vibrations from Notifications after Update" title="Pixel 6 Smartphone Suffers Weaker Vibrations from Notifications after Update"/></noscript></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://theusbport.com/pixel-6-smartphone-suffers-weaker-vibrations-from-notifications-after-update/35165" rel="bookmark" title="Pixel 6 Smartphone Suffers Weaker Vibrations from Notifications after Update">Pixel 6 Smartphone Suffers Weaker Vibrations from Notifications after Update</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://theusbport.com/more-than-11000-people-report-that-google-maps-is-down-globally/35153" rel="bookmark" title="More Than 11,000 People Report That Google Maps Is Down Globally"><img width="218" height="150" class="entry-thumb ewww_webp" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" alt="More Than 11,000 People Report That Google Maps Is Down Globally" title="More Than 11,000 People Report That Google Maps Is Down Globally" data-src-img="https://theusbport.com/wp-content/uploads/2022/03/More-Than-11000-People-Report-That-Google-Maps-Is-Down-Globally-218x150.jpg" data-src-webp="https://theusbport.com/wp-content/uploads/2022/03/More-Than-11000-People-Report-That-Google-Maps-Is-Down-Globally-218x150.jpg.webp" data-eio="j" /><noscript><img width="218" height="150" class="entry-thumb" src="https://theusbport.com/wp-content/uploads/2022/03/More-Than-11000-People-Report-That-Google-Maps-Is-Down-Globally-218x150.jpg" alt="More Than 11,000 People Report That Google Maps Is Down Globally" title="More Than 11,000 People Report That Google Maps Is Down Globally"/></noscript></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://theusbport.com/more-than-11000-people-report-that-google-maps-is-down-globally/35153" rel="bookmark" title="More Than 11,000 People Report That Google Maps Is Down Globally">More Than 11,000 People Report That Google Maps Is Down Globally</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://theusbport.com/facebook-employees-to-do-their-own-laundry-and-enjoy-late-meals/35131" rel="bookmark" title="Facebook Employees to Do Their Own Laundry and Enjoy Late Meals"><img width="218" height="150" class="entry-thumb ewww_webp" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" alt="Facebook Employees to Do Their Own Laundry and Enjoy Late Meals" title="Facebook Employees to Do Their Own Laundry and Enjoy Late Meals" data-src-img="https://theusbport.com/wp-content/uploads/2022/03/Facebook-Employees-to-Do-Their-Own-Laundry-and-Enjoy-Late-Meals-218x150.jpg" data-src-webp="https://theusbport.com/wp-content/uploads/2022/03/Facebook-Employees-to-Do-Their-Own-Laundry-and-Enjoy-Late-Meals-218x150.jpg.webp" data-eio="j" /><noscript><img width="218" height="150" class="entry-thumb" src="https://theusbport.com/wp-content/uploads/2022/03/Facebook-Employees-to-Do-Their-Own-Laundry-and-Enjoy-Late-Meals-218x150.jpg" alt="Facebook Employees to Do Their Own Laundry and Enjoy Late Meals" title="Facebook Employees to Do Their Own Laundry and Enjoy Late Meals"/></noscript></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://theusbport.com/facebook-employees-to-do-their-own-laundry-and-enjoy-late-meals/35131" rel="bookmark" title="Facebook Employees to Do Their Own Laundry and Enjoy Late Meals">Facebook Employees to Do Their Own Laundry and Enjoy Late Meals</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid-->

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://theusbport.com/super-nintendo-world-is-coming-to-the-united-states-in-2023/35134" rel="bookmark" title="Super Nintendo World Is Coming to the United States In 2023"><img width="218" height="150" class="entry-thumb ewww_webp" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" alt="Super Nintendo World Is Coming to the United States In 2023" title="Super Nintendo World Is Coming to the United States In 2023" data-src-img="https://theusbport.com/wp-content/uploads/2022/03/Super-Nintendo-World-Is-Coming-to-the-United-States-In-2023-218x150.jpg" data-src-webp="https://theusbport.com/wp-content/uploads/2022/03/Super-Nintendo-World-Is-Coming-to-the-United-States-In-2023-218x150.jpg.webp" data-eio="j" /><noscript><img width="218" height="150" class="entry-thumb" src="https://theusbport.com/wp-content/uploads/2022/03/Super-Nintendo-World-Is-Coming-to-the-United-States-In-2023-218x150.jpg" alt="Super Nintendo World Is Coming to the United States In 2023" title="Super Nintendo World Is Coming to the United States In 2023"/></noscript></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://theusbport.com/super-nintendo-world-is-coming-to-the-united-states-in-2023/35134" rel="bookmark" title="Super Nintendo World Is Coming to the United States In 2023">Super Nintendo World Is Coming to the United States In 2023</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://theusbport.com/oppo-launches-new-tech-that-fully-charges-smartphones-in-9-minutes/35117" rel="bookmark" title="Oppo Launches New Tech That Fully Charges Smartphones in 9 Minutes"><img width="218" height="150" class="entry-thumb ewww_webp" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" alt="Oppo Launches New Tech That Fully Charges Smartphones in 9 Minutes" title="Oppo Launches New Tech That Fully Charges Smartphones in 9 Minutes" data-src-img="https://theusbport.com/wp-content/uploads/2022/03/Oppo-Launches-New-Tech-That-Fully-Charges-Smartphones-in-9-Minutes-218x150.jpg" data-src-webp="https://theusbport.com/wp-content/uploads/2022/03/Oppo-Launches-New-Tech-That-Fully-Charges-Smartphones-in-9-Minutes-218x150.jpg.webp" data-eio="j" /><noscript><img width="218" height="150" class="entry-thumb" src="https://theusbport.com/wp-content/uploads/2022/03/Oppo-Launches-New-Tech-That-Fully-Charges-Smartphones-in-9-Minutes-218x150.jpg" alt="Oppo Launches New Tech That Fully Charges Smartphones in 9 Minutes" title="Oppo Launches New Tech That Fully Charges Smartphones in 9 Minutes"/></noscript></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://theusbport.com/oppo-launches-new-tech-that-fully-charges-smartphones-in-9-minutes/35117" rel="bookmark" title="Oppo Launches New Tech That Fully Charges Smartphones in 9 Minutes">Oppo Launches New Tech That Fully Charges Smartphones in 9 Minutes</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://theusbport.com/apple-announces-online-event-for-march-8-may-unveil-new-products/35107" rel="bookmark" title="Apple Announces Online Event for March 8; May Unveil New Products"><img width="218" height="150" class="entry-thumb ewww_webp" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" alt="Apple Announces Online Event for March 8; May Unveil New Products" title="Apple Announces Online Event for March 8; May Unveil New Products" data-src-img="https://theusbport.com/wp-content/uploads/2022/03/Apple-Announces-Online-Event-for-March-8-May-Unveil-New-Products-218x150.jpg" data-src-webp="https://theusbport.com/wp-content/uploads/2022/03/Apple-Announces-Online-Event-for-March-8-May-Unveil-New-Products-218x150.jpg.webp" data-eio="j" /><noscript><img width="218" height="150" class="entry-thumb" src="https://theusbport.com/wp-content/uploads/2022/03/Apple-Announces-Online-Event-for-March-8-May-Unveil-New-Products-218x150.jpg" alt="Apple Announces Online Event for March 8; May Unveil New Products" title="Apple Announces Online Event for March 8; May Unveil New Products"/></noscript></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://theusbport.com/apple-announces-online-event-for-march-8-may-unveil-new-products/35107" rel="bookmark" title="Apple Announces Online Event for March 8; May Unveil New Products">Apple Announces Online Event for March 8; May Unveil New Products</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid--></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_1_6243851771bb5" data-td_block_id="td_uid_1_6243851771bb5"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_1_6243851771bb5" data-td_block_id="td_uid_1_6243851771bb5"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> <!-- ./block -->

	<div class="comments" id="comments">
            </div> <!-- /.content -->
                                </div>
                            </div>
                            <div class="td-pb-span4 td-main-sidebar" role="complementary">
                                <div class="td-ss-main-sidebar">
                                    
 <!-- A generated by theme --> 

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-sidebar">
<script type="text/javascript">
var td_screen_width = document.body.clientWidth;

                    if ( td_screen_width >= 1140 ) {
                        /* large monitors */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-8469139019079365" data-ad-slot="9727263139"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
            
	                    if ( td_screen_width >= 1019  && td_screen_width < 1140 ) {
	                        /* landscape tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-8469139019079365" data-ad-slot="9727263139"></ins>');
	                        (adsbygoogle = window.adsbygoogle || []).push({});
	                    }
	                
                    if ( td_screen_width >= 768  && td_screen_width < 1019 ) {
                        /* portrait tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:200px;height:200px" data-ad-client="ca-pub-8469139019079365" data-ad-slot="9727263139"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                
                    if ( td_screen_width < 768 ) {
                        /* Phones */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-8469139019079365" data-ad-slot="9727263139"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                </script>
</div>

 <!-- end A --> 

<script>var block_td_uid_4_624385179c739 = new tdBlock();
block_td_uid_4_624385179c739.id = "td_uid_4_624385179c739";
block_td_uid_4_624385179c739.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"2320","category_ids":"","custom_title":"Updates You Should Not Miss","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"","header_color":"#","header_text_color":"#","ajax_pagination_infinite_stop":"","td_column_number":1,"td_ajax_preloading":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_block_widget td_uid_4_624385179c739_rand","offset":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_4_624385179c739.td_column_number = "1";
block_td_uid_4_624385179c739.block_type = "td_block_18";
block_td_uid_4_624385179c739.post_count = "5";
block_td_uid_4_624385179c739.found_posts = "388";
block_td_uid_4_624385179c739.header_color = "#";
block_td_uid_4_624385179c739.ajax_pagination_infinite_stop = "";
block_td_uid_4_624385179c739.max_num_pages = "78";
tdBlocksArray.push(block_td_uid_4_624385179c739);
</script><div class="td_block_wrap td_block_18 td_block_widget td_uid_4_624385179c739_rand td-pb-border-top"  data-td-block-uid="td_uid_4_624385179c739" ><h4 class="block-title"><span>Updates You Should Not Miss</span></h4><div id=td_uid_4_624385179c739 class="td_block_inner td-column-1">
        <div class="td_module_mx8 td_module_wrap td-animation-stack">
            <div class="meta-info-container">
                <div class="td-module-thumb"><a href="https://theusbport.com/walmart-hire-150000-workers-pay-550-million-bonuses/32054" rel="bookmark" title="Walmart to Hire 150,000 New Workers and Pay Out $550 Million in Bonuses"><img width="696" height="385" class="entry-thumb ewww_webp" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" alt="Walmart to Hire 150,000 New Workers and Pay Out $550 Million in Bonuses" title="Walmart to Hire 150,000 New Workers and Pay Out $550 Million in Bonuses" data-src-img="https://theusbport.com/wp-content/uploads/2020/03/Walmart-to-Hire-150000-New-Workers-and-Pay-Out-696x385.jpg" data-src-webp="https://theusbport.com/wp-content/uploads/2020/03/Walmart-to-Hire-150000-New-Workers-and-Pay-Out-696x385.jpg.webp" data-eio="j" /><noscript><img width="696" height="385" class="entry-thumb" src="https://theusbport.com/wp-content/uploads/2020/03/Walmart-to-Hire-150000-New-Workers-and-Pay-Out-696x385.jpg" alt="Walmart to Hire 150,000 New Workers and Pay Out $550 Million in Bonuses" title="Walmart to Hire 150,000 New Workers and Pay Out $550 Million in Bonuses"/></noscript></a></div>
                <div class="td-module-meta-info">
                    <h3 class="entry-title td-module-title"><a href="https://theusbport.com/walmart-hire-150000-workers-pay-550-million-bonuses/32054" rel="bookmark" title="Walmart to Hire 150,000 New Workers and Pay Out $550 Million in Bonuses">Walmart to Hire 150,000 New Workers and Pay Out $550 Million in Bonuses</a></h3>                                        <span class="td-author-date">
                        <span class="td-post-author-name"><a href="https://theusbport.com/author/pablo">Pablo Luna</a> <span>-</span> </span>                        <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-03-22T23:02:04+00:00" >March 22, 2020</time></span>                                            </span>
                </div>
            </div>

        </div>

        
        <div class="td_module_mx2 td_module_wrap td-animation-stack">

            <div class="td-module-thumb"><a href="https://theusbport.com/major-airlines-lay-workers-federal-bailout-small-cities-lose-air-flights/32050" rel="bookmark" title="Major Airlines to Lay Off Workers Without Federal Bailout; Small Cities Could Lose Air Flights"><img width="80" height="60" class="entry-thumb ewww_webp" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" alt="Major Airlines to Lay Off Workers Without Federal Bailout; Small Cities Could Lose Air Flights" title="Major Airlines to Lay Off Workers Without Federal Bailout; Small Cities Could Lose Air Flights" data-src-img="https://theusbport.com/wp-content/uploads/2020/03/Major-Airlines-to-Lay-Off-Workers-Without-Federal-Bailout-80x60.jpg" data-src-webp="https://theusbport.com/wp-content/uploads/2020/03/Major-Airlines-to-Lay-Off-Workers-Without-Federal-Bailout-80x60.jpg.webp" data-eio="j" /><noscript><img width="80" height="60" class="entry-thumb" src="https://theusbport.com/wp-content/uploads/2020/03/Major-Airlines-to-Lay-Off-Workers-Without-Federal-Bailout-80x60.jpg" alt="Major Airlines to Lay Off Workers Without Federal Bailout; Small Cities Could Lose Air Flights" title="Major Airlines to Lay Off Workers Without Federal Bailout; Small Cities Could Lose Air Flights"/></noscript></a></div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://theusbport.com/major-airlines-lay-workers-federal-bailout-small-cities-lose-air-flights/32050" rel="bookmark" title="Major Airlines to Lay Off Workers Without Federal Bailout; Small Cities Could Lose Air Flights">Major Airlines to Lay Off Workers Without Federal Bailout; Small Cities Could Lose Air Flights</a></h3>                <div class="td-module-meta-info">
                                                            <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-03-22T22:55:11+00:00" >March 22, 2020</time></span>                                    </div>
            </div>

        </div>

        
        <div class="td_module_mx2 td_module_wrap td-animation-stack">

            <div class="td-module-thumb"><a href="https://theusbport.com/5-trends-revolutionizing-business-world/31682" rel="bookmark" title="Out With The Old &#8211; 5 Trends That Are Revolutionizing The Business World"><img width="80" height="60" class="entry-thumb ewww_webp" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" alt="Out With The Old - 5 Trends That Are Revolutionizing The Business World" title="Out With The Old &#8211; 5 Trends That Are Revolutionizing The Business World" data-src-img="https://theusbport.com/wp-content/uploads/2020/01/Out-With-The-Old-5-Trends-That-Are-Revolutionizing-The-Business-World-80x60.jpg" data-src-webp="https://theusbport.com/wp-content/uploads/2020/01/Out-With-The-Old-5-Trends-That-Are-Revolutionizing-The-Business-World-80x60.jpg.webp" data-eio="j" /><noscript><img width="80" height="60" class="entry-thumb" src="https://theusbport.com/wp-content/uploads/2020/01/Out-With-The-Old-5-Trends-That-Are-Revolutionizing-The-Business-World-80x60.jpg" alt="Out With The Old - 5 Trends That Are Revolutionizing The Business World" title="Out With The Old &#8211; 5 Trends That Are Revolutionizing The Business World"/></noscript></a></div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://theusbport.com/5-trends-revolutionizing-business-world/31682" rel="bookmark" title="Out With The Old &#8211; 5 Trends That Are Revolutionizing The Business World">Out With The Old &#8211; 5 Trends That Are Revolutionizing The Business World</a></h3>                <div class="td-module-meta-info">
                                                            <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-01-12T12:01:04+00:00" >January 12, 2020</time></span>                                    </div>
            </div>

        </div>

        
        <div class="td_module_mx2 td_module_wrap td-animation-stack">

            <div class="td-module-thumb"><a href="https://theusbport.com/deal-selling-electric-car/30995" rel="bookmark" title="How To Get The Best Deal When Selling Your Electric Car"><img width="80" height="60" class="entry-thumb" src="https://theusbport.com/wp-content/uploads/2019/07/family-visiting-car-dealer-80x60.jpg" alt="Family Visiting Car Dealer" title="How To Get The Best Deal When Selling Your Electric Car"/></a></div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://theusbport.com/deal-selling-electric-car/30995" rel="bookmark" title="How To Get The Best Deal When Selling Your Electric Car">How To Get The Best Deal When Selling Your Electric Car</a></h3>                <div class="td-module-meta-info">
                                                            <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-07-24T10:46:31+00:00" >July 24, 2019</time></span>                                    </div>
            </div>

        </div>

        
        <div class="td_module_mx2 td_module_wrap td-animation-stack">

            <div class="td-module-thumb"><a href="https://theusbport.com/tricks-boosting-broadband-speed/30975" rel="bookmark" title="Tricks For Boosting Your Broadband Speed"><img width="80" height="60" class="entry-thumb" src="https://theusbport.com/wp-content/uploads/2019/07/woman-browsing-internet-80x60.jpg" alt="Woman Browsing Internet" title="Tricks For Boosting Your Broadband Speed"/></a></div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://theusbport.com/tricks-boosting-broadband-speed/30975" rel="bookmark" title="Tricks For Boosting Your Broadband Speed">Tricks For Boosting Your Broadband Speed</a></h3>                <div class="td-module-meta-info">
                                                            <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-07-22T12:45:51+00:00" >July 22, 2019</time></span>                                    </div>
            </div>

        </div>

        </div></div> <!-- ./block --><aside class="widget widget_text">			<div class="textwidget"><div id="contentad189306"></div>
<script type="text/javascript">
    (function(d) {
        var params =
        {
            id: "219177b9-a789-4e4b-a648-0b9d245ae1eb",
            d:  "dGhldXNicG9ydC5jb20=",
            wid: "189306",
            cb: (new Date()).getTime()
        };

        var qs=[];
        for(var key in params) qs.push(key+'='+encodeURIComponent(params[key]));
        var s = d.createElement('script');s.type='text/javascript';s.async=true;
        var p = 'https:' == document.location.protocol ? 'https' : 'http';
        s.src = p + "://api.content.ad/Scripts/widget2.aspx?" + qs.join('&');
        d.getElementById("contentad189306").appendChild(s);
    })(document);
</script>
                    </div>
		</aside><aside class="widget widget_text">			<div class="textwidget"><script type="text/javascript">
amzn_assoc_placement = "adunit0";
amzn_assoc_enable_interest_ads = "true";
amzn_assoc_tracking_id = "theusbport0a-20";
amzn_assoc_ad_mode = "auto";
amzn_assoc_ad_type = "smart";
amzn_assoc_marketplace = "amazon";
amzn_assoc_region = "US";
amzn_assoc_emphasize_categories = "16261631,51569011,2619525011,2617941011,15684181,165796011,3760911,1000,13900861,2335752011,36632,9003130011,13900871,130,172282,5088769011,979455011,2238192011,16310101,672123011,3760901,1055398,16310091,3367581,133140011,284507,195209011,599858,10272111,301668,51575011,1064954,2972638011,2619533011,229534,3375251,3250697011,228013,165793011,404272,468642,377110011";
amzn_assoc_fallback_mode = {"type":"search","value":"smartphones, computers, laptops, watches"};
amzn_assoc_default_category = "All";
</script>
<script src="//z-na.amazon-adsystem.com/widgets/onejs?MarketPlace=US"></script></div>
		</aside>                                </div>
                            </div>
                                    </div> <!-- /.td-pb-row -->
        </article> <!-- /.post -->
    </div> <!-- /.td-container -->
</div> <!-- /.td-main-content-wrap -->

<!-- Instagram -->



<!-- Footer -->


<!-- Sub Footer -->
    <div class="td-sub-footer-container">
        <div class="td-container">
            <div class="td-pb-row">
                <div class="td-pb-span7 td-sub-footer-menu">
                        <div class="menu-secondary-container"><ul id="menu-secondary-1" class="td-subfooter-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-229"><a href="https://theusbport.com/about">About</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-233"><a href="https://theusbport.com/team">Team</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-3516"><a href="https://theusbport.com/advertise">Advertise</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-231"><a href="https://theusbport.com/contact">Contact us</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-232"><a href="https://theusbport.com/privacy-policy">Privacy Policy</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-679"><a href="https://theusbport.com/terms">Terms of Use</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-234"><a href="https://theusbport.com/tip">Tip us</a></li>
</ul></div>                </div>

                <div class="td-pb-span5 td-sub-footer-copy">
                    &copy; Copyright 2021. The USB Port. All Rights Reserved.                </div>
            </div>
        </div>
    </div>
</div><!--close td-outer-wrap-->

<script type="text/javascript">var jQueryScriptOutputted = false;function initJQuery() {if (typeof(jQuery) == "undefined") {if (!jQueryScriptOutputted) {jQueryScriptOutputted = true;document.write("<scr" + "ipt type=\"text/javascript\" src=\"https://code.jquery.com/jquery-1.8.2.min.js\"></scr" + "ipt>");}setTimeout("initJQuery()", 50);}}initJQuery();</script><script type="text/javascript">jQuery(document).ready(function() {
jQuery(".aedb7ecd6e6ac675a4f1a9df508bb7a0").click(function() {
jQuery.post(
"https://theusbport.com/wp-admin/admin-ajax.php", {
"action": "quick_adsense_onpost_ad_click",
"quick_adsense_onpost_ad_index": jQuery(this).attr("data-index"),
"quick_adsense_nonce": "51c4a74e00",
}, function(response) { }
);
});
});
</script>

    <!--

        Theme: Newspaper by tagDiv 2016
        Version: 7.1.1 (rara)
        Deploy mode: deploy
        
        uid: 624385179fcbd
    -->

    <script type='text/javascript' src='https://theusbport.com/wp-content/themes/Newspaper/js/tagdiv_theme.js?ver=7.1.1' id='td-site-js'></script>
<script type='text/javascript' src='https://theusbport.com/wp-includes/js/comment-reply.min.js?ver=5.8.4' id='comment-reply-js'></script>
<script type='text/javascript' src='https://theusbport.com/wp-includes/js/wp-embed.min.js?ver=5.8.4' id='wp-embed-js'></script>
<!-- start Simple Custom CSS and JS -->
<script type="text/javascript">
if(!jQuery('.td-main-content .td-post-content a').attr('target','_blank')) {
jQuery('.td-main-content .td-post-content a').attr('target','_blank');
}</script>
<!-- end Simple Custom CSS and JS -->

<!-- JS generated by theme -->

<script>
    

	

		(function(){
			var html_jquery_obj = jQuery('html');

			if (html_jquery_obj.length && (html_jquery_obj.is('.ie8') || html_jquery_obj.is('.ie9'))) {

				var path = 'https://theusbport.com/wp-content/themes/Newspaper/style.css';

				jQuery.get(path, function(data) {

					var str_split_separator = '#td_css_split_separator';
					var arr_splits = data.split(str_split_separator);
					var arr_length = arr_splits.length;

					if (arr_length > 1) {

						var dir_path = 'https://theusbport.com/wp-content/themes/Newspaper';
						var splited_css = '';

						for (var i = 0; i < arr_length; i++) {
							if (i > 0) {
								arr_splits[i] = str_split_separator + ' ' + arr_splits[i];
							}
							//jQuery('head').append('<style>' + arr_splits[i] + '</style>');

							var formated_str = arr_splits[i].replace(/\surl\(\'(?!data\:)/gi, function regex_function(str) {
								return ' url(\'' + dir_path + '/' + str.replace(/url\(\'/gi, '').replace(/^\s+|\s+$/gm,'');
							});

							splited_css += "<style>" + formated_str + "</style>";
						}

						var td_theme_css = jQuery('link#td-theme-css');

						if (td_theme_css.length) {
							td_theme_css.after(splited_css);
						}
					}
				});
			}
		})();

	
	
</script>


</body>
</html>